<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US" prefix="og: https://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 7) | !(IE 8) ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
	

	<meta charset="UTF-8" />
	<script data-ad-client="ca-pub-6083749581068839" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	
	<title>New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk</title>
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://tamaractalk.com/xmlrpc.php">
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://feeds.feedburner.com/TamaracTalk" />	
	<link rel="pingback" href="https://tamaractalk.com/xmlrpc.php" />	
	
	
<!-- Social Warfare v4.3.0 https://warfareplugins.com - BEGINNING OF OUTPUT -->
<style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://tamaractalk.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0");
		src:url("https://tamaractalk.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0#iefix") format("embedded-opentype"),
		url("https://tamaractalk.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.3.0") format("woff"),
		url("https://tamaractalk.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.3.0") format("truetype"),
		url("https://tamaractalk.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.3.0#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>
<!-- Social Warfare v4.3.0 https://warfareplugins.com - END OF OUTPUT -->


<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<meta name="description" content="Tamarac fitness buffs are about to go retro at the Retro Fitness Grand Opening celebration."/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk" />
<meta property="og:description" content="Tamarac fitness buffs are about to go retro at the Retro Fitness Grand Opening celebration." />
<meta property="og:url" content="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842" />
<meta property="og:site_name" content="Tamarac Talk" />
<meta property="article:publisher" content="https://www.facebook.com/TamaracTalkFL" />
<meta property="article:author" content="https://www.facebook.com/TamaracTalkFL/" />
<meta property="article:section" content="Events" />
<meta property="og:image" content="https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png" />
<meta property="og:image:secure_url" content="https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta property="og:image:alt" content="New Retro Fitness in Tamarac Holds Grand Opening Event" />
<meta property="og:image:type" content="image/png" />
<meta property="article:published_time" content="2022-03-25T15:43:39-04:00" />
<meta property="og:video" content="https://www.youtube.com/embed/3mtoyCbPaxg" />
<meta property="video:duration" content="16" />
<meta property="ya:ovs:upload_date" content="2022-03-22" />
<meta property="ya:ovs:allow_embed" content="true" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk" />
<meta name="twitter:description" content="Tamarac fitness buffs are about to go retro at the Retro Fitness Grand Opening celebration." />
<meta name="twitter:creator" content="@pillcitybook" />
<meta name="twitter:image" content="https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Kevin Deutsch" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://tamaractalk.com/#organization","name":"Tamarac Talk","logo":{"@type":"ImageObject","@id":"https://tamaractalk.com/#logo","url":"https://tamaractalk.com/wp-content/uploads/2020/04/tamarac-talk-instagram.jpg","caption":"Tamarac Talk","inLanguage":"en-US","width":"787","height":"747"}},{"@type":"WebSite","@id":"https://tamaractalk.com/#website","url":"https://tamaractalk.com","name":"Tamarac Talk","publisher":{"@id":"https://tamaractalk.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png","url":"https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png","width":"800","height":"450","caption":"New Retro Fitness in Tamarac Holds Grand Opening Event","inLanguage":"en-US"},{"@type":"Person","@id":"https://tamaractalk.com/author/kevin-deutsch","name":"Kevin Deutsch","url":"https://tamaractalk.com/author/kevin-deutsch","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/d6c4bd80535e7be22f0be252c5669978?s=96&amp;d=mm&amp;r=r","url":"https://secure.gravatar.com/avatar/d6c4bd80535e7be22f0be252c5669978?s=96&amp;d=mm&amp;r=r","caption":"Kevin Deutsch","inLanguage":"en-US"},"sameAs":["https://www.facebook.com/TamaracTalkFL/","https://twitter.com/pillcitybook"],"worksFor":{"@id":"https://tamaractalk.com/#organization"}},{"@type":"WebPage","@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#webpage","url":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842","name":"New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk","datePublished":"2022-03-25T15:43:39-04:00","dateModified":"2022-03-25T15:43:39-04:00","author":{"@id":"https://tamaractalk.com/author/kevin-deutsch"},"isPartOf":{"@id":"https://tamaractalk.com/#website"},"primaryImageOfPage":{"@id":"https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png"},"inLanguage":"en-US"},{"headline":"New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk","description":"Tamarac fitness buffs are about to go retro at the Retro Fitness Grand Opening celebration.","datePublished":"2022-03-25T15:43:39-04:00","dateModified":"2022-03-25T15:43:39-04:00","image":{"@id":"https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness.png"},"author":{"@id":"https://tamaractalk.com/author/kevin-deutsch"},"@type":"NewsArticle","copyrightYear":"2022","name":"New Retro Fitness in Tamarac Holds Grand Opening Event &bull; Tamarac Talk","@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#schema-4507433","isPartOf":{"@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#webpage"},"publisher":{"@id":"https://tamaractalk.com/#organization"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#webpage"}},{"@type":"VideoObject","name":"Tamarac Grand Opening Event - Saturday, April 2nd","description":"Retro Fitness Tamarac Grand Opening and Ribbon Cutting Event Saturday, April 2nd from 10am - 2pm. Live DJ, Free Food, Raffle, Giveaways, Free Classes, and Ta...","uploadDate":"2022-03-22","thumbnailUrl":"https://tamaractalk.com/wp-content/uploads/2022/03/hqdefault.jpg","embedUrl":"https://www.youtube.com/embed/3mtoyCbPaxg","duration":"PT0M16S","width":"1280","height":"720","isFamilyFriendly":"True","@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#schema-4507434","isPartOf":{"@id":"https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842#webpage"},"publisher":{"@id":"https://tamaractalk.com/#organization"},"inLanguage":"en-US"}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Tamarac Talk &raquo; Feed" href="https://tamaractalk.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Tamarac Talk &raquo; Comments Feed" href="https://tamaractalk.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Tamarac Talk &raquo; New Retro Fitness in Tamarac Holds Grand Opening Event Comments Feed" href="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842/feed" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tamaractalk.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='social-warfare-block-css-css'  href='https://tamaractalk.com/wp-content/plugins/social-warfare/assets/js/post-editor/dist/blocks.style.build.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://tamaractalk.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='gabfire-widget-css-css'  href='https://tamaractalk.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.9.2' type='text/css' media='all' />
<style id='extendify-gutenberg-patterns-and-templates-utilities-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='set_vk_post_autor_css-css'  href='https://tamaractalk.com/wp-content/plugins/vk-post-author-display/css/vk-post-author.css?ver=1.20.0' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://tamaractalk.com/wp-content/plugins/social-warfare/assets/css/style.min.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://tamaractalk.com/wp-content/themes/sharp/framework/bootstrap/css/bootstrap.min.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://tamaractalk.com/wp-content/themes/sharp/framework/font-awesome/css/font-awesome.min.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-style-css'  href='https://tamaractalk.com/wp-content/themes/sharp/style.css?ver=5.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='vk-font-awesome-css'  href='https://tamaractalk.com/wp-content/plugins/vk-post-author-display/vendor/vektor-inc/font-awesome-versions/src/versions/6/css/all.min.css?ver=6.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css'  href='https://tamaractalk.com/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.18' type='text/css' media='all' />
<link rel='stylesheet' id='business-card-styles-css'  href='https://tamaractalk.com/wp-content/businessdirectory-themes/business-card/assets/styles.css?ver=1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=5.9.2' id='jquery-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/jquery.cycle2.min.js?ver=5.9.2' id='cycle2-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/jquery.easing.min.js?ver=5.9.2' id='easing-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/framework/bootstrap/js/bootstrap.min.js?ver=5.9.2' id='bootstrap-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/flowplayer/flowplayer.min.js?ver=5.9.2' id='flowplayer-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/jquery.tools.min.js?ver=5.9.2' id='jquerytools-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/responsive-menu.js?ver=5.9.2' id='responsive-menu-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/themes/sharp/inc/js/slides.min.jquery.js?ver=5.9.2' id='slides.min.jquery-js'></script>
<link rel="https://api.w.org/" href="https://tamaractalk.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tamaractalk.com/wp-json/wp/v2/posts/27842" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tamaractalk.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tamaractalk.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://tamaractalk.com/?p=27842' />
<link rel="alternate" type="application/json+oembed" href="https://tamaractalk.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" />
<link rel="alternate" type="text/xml+oembed" href="https://tamaractalk.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842&#038;format=xml" />

<!-- This site is using AdRotate v5.8.18 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:5px 0px 5px 0px; float:left; clear:left; }
	.g-2 { min-width:2px; max-width:354px; margin: 0 auto; }
	.b-2 { margin:5px 2px 5px 2px; }
	.g-3 { min-width:0px; max-width:600px; margin: 0 auto; }
	.b-3 { margin:0px 0px 0px 0px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
.ajdg_bnnrwidgets, .ajdg_grpwidgets { overflow:hidden; padding:0; }
.5ef78eebb9ba0, .5ef78eebba3f5 { overflow:hidden; padding:0; }
</style>
<!-- /AdRotate CSS -->

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-27922451-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-27922451-1');
</script>


<link rel="shortcut icon" href="https://tamaractalk.com/wp-content/uploads/2017/03/TamaracTalk-Logo.jpg"/>
<!-- Custom Styling -->
<style type="text/css">
.widget * {font-family:georgia, serif !important}
.entry p {font-size:16px}
.post-lead h1 {font-size:30px}
.entry p {font-family:georgia}
@media only screen and (min-width : 992px) {
.primarytop-mid .gabfire_simplead_widget {display:none}
}
.sharing-options a {
color: red !important;
background-color: white !important;
}

.sharing-options a {
background-color: YOUR_CUSTOM_COLOR_VALUE_HERE !important;
}
@media only screen and (max-width : 992px) {
.home .sidebar .gabfire_simplead_widget {display:none}

.primarytop-mid .gabfire_simplead_widget {display:block}
}
a:link {
  color: #ff0000;
}
#content .wptouch-showcase, .bottom-content-showcase .wptouch-showcase, .top-content-showcase .wptouch-showcase {
    display: none !important;
}
.Ps_scanner.aligncenter.wp-image-10607 {
width: 100%;
}
.shortcode_iframe {
width: 100%;
margin-top: -10px;
}</style>
		
			<script type='text/javascript'>
			<!--	
			(function($) {
				$.noConflict();
				$(document).ready(function() {
					$(".children").parent("li").addClass("has-child-menu");
					$(".sub-menu").parent("li").addClass("has-child-menu");
					$(".drop").parent("li").addClass("has-child-menu");
					
					$('.fadeimage').hover(
						function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
						function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
					);
					
					$('.mastheadnav li ul').hide().removeClass('fallback');
					$('.mastheadnav > li').hover(
						function () {
							$('ul', this).stop().slideDown(250);
						},
						function () {
							$('ul', this).stop().slideUp(250);
						}
					);			
					
					$('.mainnav li ul').hide().removeClass('fallback');
					$('.mainnav > li').hover(
						function () {
							$('ul', this).stop().slideDown(250);
						},
						function () {
							$('ul', this).stop().slideUp(250);
						}
					);

					$('.secondnav li ul').hide().removeClass('fallback');
					$('.secondnav > li').hover(
						function () {
							$('ul', this).stop().slideDown(250);
						},
						function () {
							$('ul', this).stop().slideUp(250);
						}
					);	
					
					$('#tabs-left').tab();
					$('#tabs > li > a').hover( function(){$(this).tab('show');});
				
					$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });		
					// Responsive Menu (TinyNav)
					$(".responsive_menu").tinyNav({
						active: 'current_page_item', // Set the "active" class for default menu
						label: ''
					});
					$(".tinynav").selectbox();
					$("ul.tabs").tabs("div.panes > div");
					$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
					$('.tooltip-link').tooltip({ placement: 'top'});

					//portfolio - show link
					$('.gallery-background').hover(
						function () {
							$(this).animate({opacity:'1'});
						},
						function () {
							$(this).animate({opacity:'0'});
						}
					);
					
				});
			})(jQuery);
			// -->
			</script>
			
			      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://tamaractalk.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '8c3d220a-1955-49dc-add1-787d4944595c';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Tamarac Talk";
oneSignal_options['welcomeNotification']['message'] = "Thanks for Subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://TamaracTalk.com";
oneSignal_options['path'] = "https://tamaractalk.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.220aec70-25f6-4973-9e9c-d6d04112ecc1";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "We would Like to Send you Notifications when we Publish New Articles.";
oneSignal_options['promptOptions']['acceptButtonText'] = "Allow";
oneSignal_options['promptOptions']['cancelButtonText'] = "No Thanks";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['tip.state.unsubscribed'] = 'Subscribe to Notifications';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You have Subscribed to Notifications';
oneSignal_options['notifyButton']['text']['tip.state.blocked'] = 'You have Blocked Notifications';
oneSignal_options['notifyButton']['text']['message.action.subscribed'] = 'Thanks for Subscribing';
oneSignal_options['notifyButton']['text']['message.action.resubscribed'] = 'You have Subscribed';
oneSignal_options['notifyButton']['text']['message.action.unsubscribed'] = 'You will not see this again';
oneSignal_options['notifyButton']['text']['dialog.main.button.subscribe'] = 'SUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.main.button.unsubscribe'] = 'UNSUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.blocked.title'] = 'Unblock notifications';
oneSignal_options['notifyButton']['text']['dialog.blocked.message'] = 'Follow these instructions to unblock notifications';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="amphtml" href="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842/amp" /><script id="google_gtagjs" src="https://www.googletagmanager.com/gtag/js?id=UA-27922451-1" async="async" type="text/javascript"></script>
<script id="google_gtagjs-inline" type="text/javascript">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());gtag('config', 'UA-27922451-1', {} );
</script>
<link rel="icon" href="https://tamaractalk.com/wp-content/uploads/2020/07/cropped-tamarac-talk-png-32x32.png" sizes="32x32" />
<link rel="icon" href="https://tamaractalk.com/wp-content/uploads/2020/07/cropped-tamarac-talk-png-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://tamaractalk.com/wp-content/uploads/2020/07/cropped-tamarac-talk-png-180x180.png" />
<meta name="msapplication-TileImage" content="https://tamaractalk.com/wp-content/uploads/2020/07/cropped-tamarac-talk-png-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.Ps_scanner.aligncenter.wp-image-10607 {
    width: 100%;
}
.shortcode_iframe {
    width: 100%;
    margin-top: -10px;
}		</style>
		<style type="text/css" media="screen">body {font-size: 17px;font-family: georgia;font-weight: normal;color: #000000;background: url(https://tamaractalk.com/wp-content/themes/sharp/framework/images/patterns/subtle-10.jpg) repeat;}article p,.entry p {font-size: 17px;font-family: georgia;font-weight: normal;color: #000000;}
							a,
							.posttitle a:hover,
							.widgetinner a,
							.post-column .highlight,
							.gab_custom_query .widgetinner a:hover,
							.primarytop-midlist .posttitle a,
							.sidebar-slider-pager a.cycle-pager-active,
							article.entry h1, article.entry h2, article.entry h3, article.entry h4, article.entry h5, article.entry h6,
							.highlightme,
							.inner-cycle .template-pager span.cycle-pager-active {color:#d81c00}

							.m_gallery .gallerycaption,
							#respond .form-submit #submit:hover,
							.sidebarsocial a:hover,
							nav .mastheadnav li ul li a:hover,
							nav .mastheadnav li li.has-child-menu > a:hover,
							nav .mainnav li ul li a:hover,
							nav .mainnav li li.has-child-menu > a:hover,
							nav .mainnav li.colored-nav-item a:hover, 
							.widget.events,
							.sidebarsocial a:hover,
							.footer-nav nav a:hover.colored-nav-item,
							.post-lead p.post-category {background-color:#d81c00}</style>
	
<!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
	<script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<script src="https://tamaractalk.com/wp-content/themes/sharp/framework/bootstrap/assets/js/respond.min.js"></script>
<![endif]-->

</head>


<body data-rsssl=1 class="post-template-default single single-post postid-27842 single-format-standard fa_v6_css wpbdp-with-button-styles">
	
	

<div class="site-masthead">
	<div class="container">
		<div class="row">
			<nav class="col-md-12">
				<ul class="mastheadnav responsive_menu">
					<li class="firstli"><a href="https://tamaractalk.com/" title="The #1 News Source for Tamarac, Florida">Home</a></li>
					<li id="menu-item-18750" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-has-children menu-item-18750"><a href="https://tamaractalk.com/about">About Tamarac Talk</a>
<ul class="sub-menu">
	<li id="menu-item-21465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21465"><a href="https://tamaractalk.com/policies">Policies</a></li>
</ul>
</li>
<li id="menu-item-21511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21511"><a href="https://tamaractalk.com/got-a-hot-tip">Submit News</a></li>
<li id="menu-item-18749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18749"><a href="https://tamaractalk.com/contact">Contact</a></li>
<li id="menu-item-18748" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18748"><a href="https://tamaractalk.com/advertise">Advertise</a></li>
<li id="menu-item-18809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18809"><a href="https://tamaractalk.com/subscribe-to-tamarac-talk">Subscribe to Tamarac Talk</a></li>
<li id="menu-item-27182" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27182"><a href="#weglot_switcher">Weglot Switcher</a></li>
					 
											<li class="pull-right social_header">
															<a href="https://www.facebook.com/TamaracTalkFL" data-toggle="tooltip" title="Facebook" rel="nofollow"><span>Friend on Facebook</span>
									<i class="fa fa-facebook pull-left"></i>
								</a>
							
															<a href="https://twitter.com/TamaracTalk" title="Twitter" rel="nofollow"><span>Follow on Facebook</span>
									<i class="fa fa-twitter pull-left"></i>
								</a>
							
															<a href="https://plus.google.com/u/0/108963751975675293333/posts" title="Google+" rel="nofollow"><span>Add to Google+ Circle</span>
									<i class="fa fa-google-plus pull-left"></i>
								</a>
							
							
														
														
							
														
															<a href="https://www.youtube.com/channel/UCNFJYie7wwhGkB-EDM27pCQ" title="Youtube" rel="nofollow"><span>Watch on YouTube</span>
									<i class="fa fa-youtube pull-left"></i>
								</a>
								

															<a href="http://eepurl.com/dNDyRM" title="Subscribe by Email" rel="nofollow"><span>Subscribe by Email</span>
									<i class="fa fa-envelope-o pull-left"></i>
								</a>
															

							<a href="http://feeds.feedburner.com/TamaracTalk" title="Site feed" rel="nofollow">
								<span>Subscribe to RSS</span> <i class="fa fa-rss pull-left"></i>
							</a>
							
												
					</li>
					<li class="pull-right gab_headersearch"> <a data-toggle="modal" href="#searchModal"><i class="fa fa-search"></i> Search</a></li>
				</ul>
			</nav>

			<!-- Modal -->
			<div class="modal fade" id="searchModal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
				<div class="modal-dialog">
				  <div class="modal-content">
					<div class="modal-header">
					  <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
					  <h4 class="modal-title">Search in Site</h4>
					</div>
					<div class="modal-body">
						<form action="https://tamaractalk.com/">
							<div class="input-prepend">
								<label>To search in site, type your keyword and hit enter</label>
								<input type="text" name="s" class="form-control" placeholder="Type keyword and hit enter">
							</div>
						</form>	
					</div>
					<div class="modal-footer">
					  <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
					</div>
				  </div><!-- /.modal-content -->
				</div><!-- /.modal-dialog -->
			</div><!-- /.modal -->
		</div><!-- /.row -->		
	</div>
</div>

<div class="container">
	<header class="row">
		<div class="col-sm-12 col-md-12 col-lg-5">
			<div class="sitelogo" style="padding:0px 0px 0px 0px;">		
									<h1>
						<a href="https://tamaractalk.com/" title="The #1 News Source for Tamarac, Florida">
							<img src="https://tamaractalk.com/wp-content/uploads/2015/02/TT215.jpg" alt="Tamarac Talk" title="Tamarac Talk"/>
						</a>
					</h1>
								<div class="clearfix"></div>
			</div><!-- .logo -->
		</div>
		
		<div class="headerbanner col-sm-12 col-md-12 col-lg-7 pull-right hidden-xs" style="padding-top:0px"><div class="innerad"><a href="http://www.13thfloorhomes.com/hidden-trails/single-family-homes/?utm_source=Tamarac+Talk&amp;utm_medium=Ad+%231&amp;utm_content=view+floorplans&amp;utm_campaign=Hidden-trails-tamarac-talk" target="_blank" rel="noopener"> <img class="aligncenter  wp-image-21443" src="https://tamaractalk.com/wp-content/uploads/2019/07/HiddenTrails.jpeg" alt="" width="628" height="70" /></a></div></div>	</header>
	
	<section class="row site-nav">
		<div class="col-md-12">
			<nav class="main-navigation">
				<ul class="mainnav responsive_menu">
					<li id="menu-item-21462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-21462"><a href="https://tamaractalk.com/">Home</a>
<ul class="sub-menu">
	<li id="menu-item-27607" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27607"><a href="https://tamaractalk.com/coral-springs-news">Coral Springs News</a></li>
	<li id="menu-item-25559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25559"><a href="https://tamaractalk.com/broward-county-public-schools-color-calendar-25282">2021/2022 Broward School Color Calendar</a></li>
	<li id="menu-item-26851" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-26851"><a href="https://tamaractalk.com/2022-garbage-recycling-bulk-trash-schedule-26847">2022 Garbage Recycling and Bulk Trash Schedule for Tamarac</a></li>
	<li id="menu-item-26846" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-26846"><a href="https://tamaractalk.com/2022-hazardous-waste-drop-off-dates-26844">2022 Hazardous Waste Drop-Off Dates for Tamarac Residents</a></li>
</ul>
</li>
<li id="menu-item-21463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21463"><a href="https://tamaractalk.com/business-directory">Business Directory</a></li>
				
						<li class="color1 colored-nav-item"><a href="https://tamaractalk.com/category/sports" style="background-color:#dd3333">Sports</a>
</li>
				
						<li class="color2 colored-nav-item"><a href="https://tamaractalk.com/category/dining-2" style="background-color:#d1bb30">Dining</a>
</li>
				
						<li class="color3 colored-nav-item"><a href="https://tamaractalk.com/category/politics" style="background-color:#e56c02">Politics</a>
</li>
				
						<li class="color4 colored-nav-item"><a href="https://tamaractalk.com/category/school" style="background-color:#4e8abf">Schools</a>
</li>
				
						<li class="color5 colored-nav-item"><a href="https://tamaractalk.com/category/events" style="background-color:#81d742">Events</a>
</li>
				
						<li class="color6 colored-nav-item"><a href="https://tamaractalk.com/category/crime-and-safety" style="background-color:#000000">Crime &amp; Safety</a>
</li>
				
						<li class="color7 colored-nav-item"><a href="https://tamaractalk.com/category/news" style="background-color:#dd3333">News</a>
</li>
				</ul>
			</nav>
		</div>
	</section>		
	
		<section class="row">
		<div class="col-md-12">
			<div class="post-lead">
				<p class="post-category"><a href="https://tamaractalk.com/category/events" rel="category tag">Events</a> &middot; <a href="https://tamaractalk.com/category/news" rel="category tag">News</a></p>
				<h1 class="post-title">New Retro Fitness in Tamarac Holds Grand Opening Event</h1>
				<p class="post-datecomment">
					March 25, 2022 by <a href="https://tamaractalk.com/author/kevin-deutsch">Kevin Deutsch</a>					
					<span class="commentnr">No Comments</span>				</p>
				
							</div>
		</div>
	</section>
		
	<section class="row">
	<div class="col-xs-12 col-md-8">		
				
		<article class="entry post-27842 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-news last_archivepost">		
				<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="none" data-float-mobile="none" data-transition="slide" data-post-id="27842" ><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=New+Retro+Fitness+in+Tamarac+Holds+Grand+Opening+Event&url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842&via=pillcitybook" data-link="https://twitter.com/intent/tweet?text=New+Retro+Fitness+in+Tamarac+Holds+Grand+Opening+Event&url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842&via=pillcitybook"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div></div><div class="g g-1"><div class="g-single a-70"><a class="gofollow" data-track="NzAsMSwxLDYw" href="https://helenasells.com/contact/"><img class="size-full wp-image-34331 alignnone" src="https://coralspringstalk.com/wp-content/uploads/2021/08/Helena-REMAX-Direct-AD2.gif" alt="" width="728" height="90" /></a></div></div><p><iframe title="YouTube video player" src="https://www.youtube.com/embed/3mtoyCbPaxg" width="800" height="450" frameborder="0" allowfullscreen="allowfullscreen"><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span></iframe></p>
<p style="text-align: justify;"><strong><em>By Kevin Deutsch</em></strong></p>
<p style="text-align: justify;">Tamarac fitness buffs are about to go retro.</p>
<p style="text-align: justify;"><a href="https://urldefense.proofpoint.com/v2/url?u=https-3A__retrofitness.com_&amp;d=DwMFAg&amp;c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&amp;r=yq7YMLOn0rfmOKljacjQO0pe0wDjgc7Z4oj8Q2rIt2U&amp;m=nsyoOhSvbCp6hfXv7-ZGEGjRJXMNBOVqxEnZq8kaM_8&amp;s=cpn5t4CGph7sLF7YY3jFD3MsRiWHHB7TX_AfaMsU-Mg&amp;e=" target="_blank" rel="noopener">Retro Fitness</a> will host a grand opening event for its new fitness club at 8129 N. Pine Island on Saturday, April 2, from 10 a.m. to 2 p.m.</p>
<p style="text-align: justify;">“Retro Fitness is excited to bring exercise, health, and fitness to the Tamarac community,&#8221; said Todd Scartozzi, Chief Operation Officer. &#8220;Our new&#8230;gym concept offers members an unparalleled experience with world-class equipment, Zen amenities like massage, tanning, red light therapy all in an environment that emphasizes community.&#8221;</p>
<p style="text-align: justify;">A written announcement about the grand opening event called Retro Fitness, the “leading national fitness franchise with more than 120 gyms open or in development across the country.”</p><div class="g g-2"><div class="g-col b-2 a-75"><a class="gofollow" data-track="NzUsMiwxLDYw" href="https://retrofitness.com/location/tamarac/"><img class=" wp-image-35612 alignnone" src="https://coralspringstalk.com/wp-content/uploads/2021/10/Retro-Fitness.jpg" alt="Retro Fitness Tamarac" width="350" height="250" /></a></div></div>
<p style="text-align: justify;">The Tamarac fitness center, the announcement said, is “the first of many to debut the company’s initiative to transform all current gyms into state-of-the-art health clubs that strengthen the member experience through innovative technologies, equipment, and an even more enhanced community focus.”</p>
<p style="text-align: justify;">The grand opening event will include a raffle with prizes that include a 50-inch Amazon flat-screen television and a bike cruiser. According to the announcement, all profits from the raffle will be donated to the <a href="https://www.tnlcoc.org/foundation/" target="_blank" rel="noopener">Tamarac North Lauderdale Chamber of Commerce Foundation</a>.</p>
<p style="text-align: justify;">The event will also feature a DJ playing music, food for attendees, and free on-site exercise classes.</p>
<p style="text-align: justify;">Several Tamarac city officials are expected to attend, including Mayor Michelle Gomez, Vice Mayor Mike Gelin, Commissioners Marlon Bolton, Debra Placko, Elvin Villalobos, and City Manager Kathleen Gunn, the announcement states.</p>
<p style="text-align: justify;"><em>Got News? Send it to </em><a href="https://tamaractalk.com/got-a-hot-tip"><em>Tamarac Talk</em></a><em>.</em></p>
<div class="padSection" id="padSection"><h4>Author Profile</h4><div id="avatar" class="avatar square"><img src="https://tamaractalk.com/wp-content/uploads/2021/06/Kevin-deutsch-sq-150x150.jpg" alt="Kevin Deutsch" /></div><!-- [ /#avatar ] --><dl id="profileTxtSet" class="profileTxtSet">
<dt>
<span id="authorName" class="authorName">Kevin Deutsch</span></dt><dd>
Kevin Deutsch is an award-winning crime journalist and author. A graduate of Florida International University, Kevin has worked on staff at The Miami Herald, New York Daily News, and The Palm Beach Post.
<ul class="sns_icons"><li class="pad_twitter"><a href="https://twitter.com/pillcitybook" target="_blank" class="twitter" rel="noopener"><i class="fab fa-twitter-square" aria-hidden="true"></i></a></li><li class="pad_facebook"><a href="https://www.facebook.com/TamaracTalkFL" target="_blank" class="facebook" rel="noopener"><i class="fab fa-facebook-square" aria-hidden="true"></i></a></li><li class="pad_instagram"><a href="https://www.instagram.com/tamaractalk/" target="_blank" class="instagram" rel="noopener"><i class="fab fa-instagram" aria-hidden="true"></i></a></li><li class="pad_youtube"><a href="https://www.youtube.com/channel/UCYOhm1unNpEQK5yrS3ZjyhA" target="_blank" class="youtube" rel="noopener"><i class="fab fa-youtube-square" aria-hidden="true"></i></a></li><li class="pad_linkedin"><a href="https://www.linkedin.com/company/talk-media-inc" target="_blank" class="linkedin" rel="noopener"><i class="fab fa-linkedin" aria-hidden="true"></i></a></li><li class="pad_amazon"><a href="http://SharonBaron1" target="_blank" class="amazon"><i class="fab fa-amazon" aria-hidden="true"></i></a></li></ul></dd></dl><div id="latestEntries">
<h5>Latest entries</h5>
<ul class="entryList">
<li class="thumbnailBox"><span class="inner-box"><span class="postImage"><a href="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842"><img width="50" height="50" src="https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-50x50.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="New Retro Fitness in Tamarac Holds Grand Opening Event" loading="lazy" srcset="https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-50x50.png 50w, https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-150x150.png 150w, https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-144x144.png 144w, https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-400x400.png 400w, https://tamaractalk.com/wp-content/uploads/2022/03/retro-fitness-30x30.png 30w" sizes="(max-width: 50px) 100vw, 50px" /><a class="padCate" style="background-color:#999999" href="https://tamaractalk.com/category/events">Events</a></a></span></span><span class="padDate">2022.03.25</span><a href="https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842" class="padTitle">New Retro Fitness in Tamarac Holds Grand Opening Event</a></li>
<li class="thumbnailBox"><span class="inner-box"><span class="postImage"><a href="https://tamaractalk.com/man-shot-on-state-road-7-in-tamarac-27843"><img width="50" height="50" src="https://tamaractalk.com/wp-content/uploads/2022/02/police-2-50x50.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="bicyclist killed in Tamarac" loading="lazy" srcset="https://tamaractalk.com/wp-content/uploads/2022/02/police-2-50x50.jpeg 50w, https://tamaractalk.com/wp-content/uploads/2022/02/police-2-150x150.jpeg 150w, https://tamaractalk.com/wp-content/uploads/2022/02/police-2-144x144.jpeg 144w, https://tamaractalk.com/wp-content/uploads/2022/02/police-2-400x400.jpeg 400w, https://tamaractalk.com/wp-content/uploads/2022/02/police-2-30x30.jpeg 30w" sizes="(max-width: 50px) 100vw, 50px" /><a class="padCate" style="background-color:#999999" href="https://tamaractalk.com/category/news">News</a></a></span></span><span class="padDate">2022.03.25</span><a href="https://tamaractalk.com/man-shot-on-state-road-7-in-tamarac-27843" class="padTitle">Man Shot on State Road 7 in Tamarac</a></li>
<li class="thumbnailBox"><span class="inner-box"><span class="postImage"><a href="https://tamaractalk.com/rep-cherfilus-mccormick-visit-to-israel-27823"><img width="50" height="50" src="https://tamaractalk.com/wp-content/uploads/2022/03/sheila-50x50.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Sheila Cherfilus-McCormick during her swearing in ceremony. {Instagram}" loading="lazy" srcset="https://tamaractalk.com/wp-content/uploads/2022/03/sheila-50x50.png 50w, https://tamaractalk.com/wp-content/uploads/2022/03/sheila-150x150.png 150w, https://tamaractalk.com/wp-content/uploads/2022/03/sheila-144x144.png 144w, https://tamaractalk.com/wp-content/uploads/2022/03/sheila-400x400.png 400w, https://tamaractalk.com/wp-content/uploads/2022/03/sheila-30x30.png 30w" sizes="(max-width: 50px) 100vw, 50px" /><a class="padCate" style="background-color:#999999" href="https://tamaractalk.com/category/news">News</a></a></span></span><span class="padDate">2022.03.23</span><a href="https://tamaractalk.com/rep-cherfilus-mccormick-visit-to-israel-27823" class="padTitle">&#8220;We Will No Longer Let Hate Grow&#8221;: Congresswoman Cherfilus-McCormick Invokes Visit To Israel&#8217;s Holocaust Museum During Town Hall</a></li>
<li class="thumbnailBox"><span class="inner-box"><span class="postImage"><a href="https://tamaractalk.com/eight-residents-displaced-by-fire-in-tamarac-27816"><img width="50" height="50" src="https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="tamarac fire" loading="lazy" srcset="https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-50x50.jpg 50w, https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-150x150.jpg 150w, https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-144x144.jpg 144w, https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-400x400.jpg 400w, https://tamaractalk.com/wp-content/uploads/2022/03/276166709_286572243618258_7712514888794318394_n-e1647911965259-30x30.jpg 30w" sizes="(max-width: 50px) 100vw, 50px" /><a class="padCate" style="background-color:#999999" href="https://tamaractalk.com/category/news">News</a></a></span></span><span class="padDate">2022.03.21</span><a href="https://tamaractalk.com/eight-residents-displaced-by-fire-in-tamarac-27816" class="padTitle">8 Residents Displaced by Fire in Tamarac</a></li>
</ul>
</div>
</div></p><div class="g g-1"><div class="g-single a-70"><a class="gofollow" data-track="NzAsMSwxLDYw" href="https://helenasells.com/contact/"><img class="size-full wp-image-34331 alignnone" src="https://coralspringstalk.com/wp-content/uploads/2021/08/Helena-REMAX-Direct-AD2.gif" alt="" width="728" height="90" /></a></div></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="none" data-float-mobile="none" data-transition="slide" data-post-id="27842" ><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=New+Retro+Fitness+in+Tamarac+Holds+Grand+Opening+Event&url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842&via=pillcitybook" data-link="https://twitter.com/intent/tweet?text=New+Retro+Fitness+in+Tamarac+Holds+Grand+Opening+Event&url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842&via=pillcitybook"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Ftamaractalk.com%2Ftamarac-retro-fitness-grand-opening-event-27842"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div></div><div class="swp-content-locator"></div><section id="block-8" class="widget widget_block widget_text"><div class="widgetinner">
<p><script>document.addEventListener( 'DOMContentLoaded', function( event ) {	var data = {		action: 'disqus_latest_ajax',		attr: '6c697b5e-9d21-402d-9440-846ac6ba2cf5',	};	jQuery.post( 'https://tamaractalk.com/wp-admin/admin-ajax.php', data, function( response ) {		jQuery( '.dsq-widget-list-wrapper.6c697b5e-9d21-402d-9440-846ac6ba2cf5' ).html( response );	});})</script><div class='dsq-widget-list-wrapper 6c697b5e-9d21-402d-9440-846ac6ba2cf5'></div></p>
</div></section>
<section id="text-91" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="g g-3"><div class="g-col b-3 a-57"><a class="gofollow" data-track="NTcsMywxLDYw" href="https://www.floridacharterbuscompany.com/miami-charter-bus"><img class=" wp-image-31913 size-medium" src="https://coralspringstalk.com/wp-content/uploads/2021/04/Miami-Charter-Bus-Company-400x233.jpg" alt="Miami Charter Bus Company" width="300" height="150" /></a></div><div class="g-col b-3 a-58"><p class="p1" style="text-align: justify;"><a class="gofollow" data-track="NTgsMywxLDYw" href="https://www.eventbrite.com/o/w2tf-llc-18872656262"><img class="size-medium wp-image-32648 alignnone" src="https://coralspringstalk.com/wp-content/uploads/2021/05/W2TF-Business-Card-2-400x210.jpg" alt="" width="300" height="150" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-73"><p style="text-align: justify;"><a class="gofollow" data-track="NzMsMywxLDYw" href="https://boardroompr.com/"><img class="aligncenter wp-image-28170 size-medium" src="https://coralspringstalk.com/wp-content/uploads/2020/08/BoardroomPR-BC-Todd-Ad-400x229.jpg" alt="Boardroompr" width="300" height="150" /></a></p></div><div class="g-col b-3 a-81"><a class="gofollow" data-track="ODEsMywxLDYw" href="https://marcosfuentes.latestfloridalistings.com/"><img class="aligncenter wp-image-14274" src="https://parklandtalk.com/wp-content/uploads/2022/02/marcos-fuentes-remax-400x235.jpg" alt="marcos fuentes re/max" width="300" height="150" /></a></div></div>
</div>
		</div></section>
				
				
<div id="disqus_thread"></div>
		</article>					
	</div><!-- col-md-8 --><div class="clearfix hidden-lg hidden-md"></div>

	<aside class="col-md-4 sidebar">
			<section id="text-93" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-74"><a class="gofollow" data-track="NzQsMCwxLDYw" href="https://yoursmileclinic.com/"><img class="alignnone wp-image-35415" src="https://coralspringstalk.com/wp-content/uploads/2021/10/smile-clinic-coralsprings-FINAL-400x286.jpg" alt="" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-99" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Error, Ad (52) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! -->
</div>
		</div></section>
<section id="text-94" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-10"><a class="gofollow" data-track="MTAsMCwxLDYw" href="http://www.mrpoolservice.com/"><img class="alignnone size-full wp-image-17882" src="https://tamaractalk.com/wp-content/uploads/2016/10/MrPoolsvc.jpg" alt="mrpoolsvc" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-109" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-83"><a class="gofollow" data-track="ODMsMCwxLDYw" href="https://www.smile-practice.com/contact-us/"><img class="alignnone size-full wp-image-10352" src="https://margatetalk.com/wp-content/uploads/2-smile.gif" alt="Smile Dentistry" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-105" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-76"><a class="gofollow" data-track="NzYsMCwxLDYw" href="https://cutlerrader.com/"><img class="alignnone size-full wp-image-35998" src="https://coralspringstalk.com/wp-content/uploads/2021/11/Cutler-Rader-jpg.jpeg" alt="" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-96" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Error, Ad (59) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! -->
</div>
		</div></section>
<section id="text-107" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><p class="p1"><div class="a-single a-79"><a class="gofollow" data-track="NzksMCwxLDYw" href="https://urldefense.proofpoint.com/v2/url?u=https-3A__coral-2Dsprings.gosarpinos.com_-3Futm-5Fsource-3DCoralSpringsTalk-26utm-5Fmedium-3DBanner-26utm-5Fcampaign-3DFl-26utm-5Fid-3DLocalDigital&amp;d=DwMFaQ&amp;c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&amp;r=yq7YMLOn0rfmOKljacjQO0pe0wDjgc7Z4oj8Q2rIt2U&amp;m=A66zVrx45odL0mI8xUSbhjBvn40Ycb1Ybdpbjca04ME&amp;s=S4RrCZgrPMgS_xBQirbhHldT5G2-KFx_2ZsUgEnTz-k&amp;e="><img class="alignnone size-full wp-image-37379" src="https://coralspringstalk.com/wp-content/uploads/2022/01/Sarpinos-2022.png" alt="" width="350" height="250" /></a></div></p>
</div>
		</div></section>
<section id="text-98" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-8"><a class="gofollow" data-track="OCwwLDEsNjA=" href="https://www.facebook.com/ROG-Properties-LLC-100107805947938/"><img class="alignnone size-full wp-image-27611" src="https://tamaractalk.com/wp-content/uploads/2022/03/Rog-Properties-350-×-250-px-1.png" alt="ROG Properties" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-100" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-65"><a class="gofollow" data-track="NjUsMCwxLDYw" href="https://www.adambaronlaw.com/"><img class="aligncenter size-full wp-image-33641" src="https://coralspringstalk.com/wp-content/uploads/2021/06/Adam-Baron-Law_TalkMedia_350x250-3.jpg" alt="" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-102" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-14"><a class="gofollow" data-track="MTQsMCwxLDYw" href="https://www.nothingbundtcakes.com/bakery/FL/coral-springs?utm_source=google&amp;utm_medium=gmb"><img class="alignnone size-full wp-image-23176" src="https://tamaractalk.com/wp-content/uploads/2020/07/Nothing-Bundt-2020.jpg" alt="" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-95" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Error, Ad (61) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! -->
</div>
		</div></section>
<section id="text-106" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Error, Ad (78) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! -->
</div>
		</div></section>
<section id="text-101" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-66"><a class="gofollow" data-track="NjYsMCwxLDYw" href="https://tamarac.org/1130/Commissioner---Elvin-Villalobos-Dist-3"><img class="size-full wp-image-27294 alignnone" src="https://tamaractalk.com/wp-content/uploads/2022/02/Elvin.png" alt="Elvin Villalobos" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-97" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-11"><a class="gofollow" data-track="MTEsMCwxLDYw" href="https://www.13thfloorhomes.com/hidden-trails/schedule-a-visit/?utm_source=Tamarac+Talk&amp;utm_medium=Ad+%232&amp;utm_content=new+models+open&amp;utm_campaign=Hidden-trails-tamarac-talk"><img class="size-full wp-image-23174 alignnone" src="https://tamaractalk.com/wp-content/uploads/2020/07/Hidden-trails2020.jpg" alt="" width="350" height="250" /></a></div>
</div>
		</div></section>
<section id="text-104" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><div class="a-single a-75"><a class="gofollow" data-track="NzUsMCwxLDYw" href="https://retrofitness.com/location/tamarac/"><img class=" wp-image-35612 alignnone" src="https://coralspringstalk.com/wp-content/uploads/2021/10/Retro-Fitness.jpg" alt="Retro Fitness Tamarac" width="350" height="250" /></a></div>
</div>
		</div></section>
		
						
			
			<div class="search-wrapper">
	<div class="search-inner">
		<form class="form-wrapper cf" action="https://tamaractalk.com/">
			<input type="text" name="s" placeholder="Search in site..." required>
			<button type="submit">Search</button>
		</form>
	</div>
</div>

<div class="clearfix visible-sm"></div>			
			<section id="wpbdp_latestlistingswidget-2" class="widget widget_wpbdp_latestlistingswidget"><div class="widgetinner"><ul class="wpbdp-listings-widget-list"><li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/rog-properties"><img width="350" height="250" src="https://tamaractalk.com/wp-content/uploads/2022/03/Rog-Properties-350-×-250-px-1.png" class="listing-image" alt="ROG Properties" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/rog-properties">ROG Properties</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/marcos-fuentes-re-max-select"><img width="350" height="206" src="https://tamaractalk.com/wp-content/uploads/2022/02/marcos-fuentes-remax-350x206.jpg" class="listing-image" alt="marcos fuentes" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/marcos-fuentes-re-max-select">Marcos Fuentes RE/MAX Select</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/aftermath-adjusters-consulting"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2022/01/Aftermath-final-350x200.jpg" class="listing-image" alt="Aftermath Adjusters and Consultants" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/aftermath-adjusters-consulting">Aftermath Adjusters and Consulting</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/sarpinos-pizzaria"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2022/01/Sarpinos-2022-CARD-350x200.jpg" class="listing-image" alt="sarpino&#039;s" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/sarpinos-pizzaria">Sarpino&#8217;s Pizzaria</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/retro-fitness"><img width="350" height="197" src="https://tamaractalk.com/wp-content/uploads/2021/12/Retro-Fitness-Business-Card-350x197.jpeg" class="listing-image" alt="Retro Fitness" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/retro-fitness">Retro Fitness</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/bright-shine-dental"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2021/12/Bright-Shine-Dental-2022-350x200.jpeg" class="listing-image" alt="Bright &amp; Shine Dental" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/bright-shine-dental">Bright &#038; Shine Dental</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/cutler-rader"><img width="350" height="197" src="https://tamaractalk.com/wp-content/uploads/2021/11/Cutler-Rader-Card-350x197.jpg" class="listing-image" alt="cutler rader" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/cutler-rader">Cutler Rader</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/smile-clinic-coral-springs"><img width="350" height="201" src="https://tamaractalk.com/wp-content/uploads/2021/10/smile-clinic-business-card-featured-350x201.jpg" class="listing-image" alt="Smile Clinic of Coral Springs" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/smile-clinic-coral-springs">Smile Clinic of Coral Springs</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/kryptonite-mobile-lab-services"><img width="350" height="198" src="https://tamaractalk.com/wp-content/uploads/2021/09/kryptonite-1-350x198.jpg" class="listing-image" alt="kryptonite" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/kryptonite-mobile-lab-services">Kryptonite Mobile Lab Services</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/helena-yeaman-realtor-remax"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2021/08/Helena-business-card-2021-2-350x200.jpg" class="listing-image" alt="helena" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/helena-yeaman-realtor-remax">Helena Yeaman, Realtor</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/re-max-interaction-realty"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2021/07/Elvin-ReMax_BcardAds2-350x200.jpg" class="listing-image" alt="RE/Max Interaction realty" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/re-max-interaction-realty">RE/MAX InterAction Realty</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/transnora-limo"><img width="350" height="210" src="https://tamaractalk.com/wp-content/uploads/2021/07/transnora-limo-350x210.jpg" class="listing-image" alt="Transnora Limo" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/transnora-limo">Transnora Limo</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/maesk-counseling"><img width="350" height="191" src="https://tamaractalk.com/wp-content/uploads/2021/06/Card-newer-350x191.jpg" class="listing-image" alt="Maesk" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/maesk-counseling">Maesk Counseling</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<li class="wpbdp-listings-widget-item wpbdp-listings-widget-item-with-left-thumbnail-in-desktop wpbdp-listings-widget-item-with-thumbnail-above-in-mobile "><div class="wpbdp-listings-widget-container"><div class="wpbdp-listings-widget-thumb"><a href="https://tamaractalk.com/business-directory/sam-fast-p-a-real-estate-professional-property-manager"><img width="350" height="200" src="https://tamaractalk.com/wp-content/uploads/2021/06/Sam-Fast-PA-350x200.jpg" class="listing-image" alt="Sam Fast" loading="lazy" /></a></div><div class="wpbdp-listings-widget-item--title-and-content"><div class="wpbdp-listing-title"><a class="listing-title" href="https://tamaractalk.com/business-directory/sam-fast-p-a-real-estate-professional-property-manager">Sam Fast P.A. Real Estate Professional | Property Manager</a></div> <div class="wpbdp-listing-fields"></div></div></li>
<style>#wpbdp_latestlistingswidget-2 .listing-image{max-width:350px;}</style></ul></div></section>
						
						
					</aside>
</section>	
		
	
	<section class="row footer-nav hidden-xs">
		<div class="col-md-12">	
			<div class="footernav-innerdiv">
			
								
				<nav>		
									
						<a class="color1 colored-nav-item" style="background-color:#dd3333" href="https://tamaractalk.com/category/sports">Sports</a>
				
						<a class="color2 colored-nav-item" style="background-color:#d1bb30" href="https://tamaractalk.com/category/dining-2">Dining</a>
				
						<a class="color3 colored-nav-item" style="background-color:#e56c02" href="https://tamaractalk.com/category/politics">Politics</a>
				
						<a class="color4 colored-nav-item" style="background-color:#4e8abf" href="https://tamaractalk.com/category/school">Schools</a>
				
						<a class="color5 colored-nav-item" style="background-color:#81d742" href="https://tamaractalk.com/category/events">Events</a>
				
						<a class="color6 colored-nav-item" style="background-color:#000000" href="https://tamaractalk.com/category/crime-and-safety">Crime &amp; Safety</a>
				
						<a class="color7 colored-nav-item" style="background-color:#dd3333" href="https://tamaractalk.com/category/news">News</a>
				</nav>
				<div class="clearfix"></div>
			</div>
		</div>
	</section>
	
	<footer>
		<div class="row">
			<div class="col-xs-12 col-sm-7 col-md-4">
							</div>
			
			<div class="col-xs-12 col-sm-5 col-md-3">
							</div>
			
			<div class="clearfix visible-sm"></div>
			
			<div class="col-xs-12 col-sm-3 col-md-2">
							</div>
			
			<div class="col-xs-12 col-sm-9 col-md-3 footerlast">
							</div>
		</div>
		
		<div class="row">
			<div class="col-md-12">
				<div class="footer-secondrow">			
					<div class="navwidgets navwidgets-1">
						<div>
													</div>
					</div>
					
					<div class="navwidgets navwidgets-2">
						<div>
													</div>
					</div>

					<div class="clearfix visible-xs"></div>
					
					<div class="navwidgets navwidgets-3">
						<div>
													</div>
					</div>

					<div class="navwidgets navwidgets-4">
						<div>
													</div>
					</div>

					<div class="navwidgets navwidgets-5">
						<div>
													</div>
					</div>					
				</div>
			</div>
		</div>
		
		<div class="row">
			<div class="col-md-12">
				<div class="footer-meta">
				
					<p class="footer-metaleft pull-left">
													&copy; 2022, <a href="#top" title="Tamarac Talk" rel="home"><strong>&uarr;</strong> Tamarac Talk</a>
											</p><!-- #site-info -->
								
					<p class="footer-metaleft pull-right">
						<a rel="nofollow" href="https://tamaractalk.com/wp-login.php">Log in</a> - 			
												<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator"></a> - 
						Talk Media</a> 
						
					</p> <!-- #footer-right-side -->
				</div>
			</div>
		</div>
	</footer>
</div><!-- container -->

<!-- Powered by WPtouch Pro: 4.3.38 -->					<div id="fb-root"></div>
					<script type='text/javascript'>
					<!--
					(function(d, s, id) {
					  var js, fjs = d.getElementsByTagName(s)[0];
					  if (d.getElementById(id)) return;
					  js = d.createElement(s); js.id = id;
					  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
					  fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));
					// -->
					</script>
				<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/tamaractalk.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"tamaractalk"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"27842 https:\/\/tamaractalk.com\/?p=27842","disqusShortname":"tamaractalk","disqusTitle":"New Retro Fitness in Tamarac Holds Grand Opening Event","disqusUrl":"https:\/\/tamaractalk.com\/tamarac-retro-fitness-grand-opening-event-27842","postId":"27842"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' id='social_warfare_script-js-extra'>
/* <![CDATA[ */
var socialWarfare = {"addons":["pro"],"post_id":"27842","variables":{"emphasizeIcons":"0","powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=4.3.0' id='social_warfare_script-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-includes/js/comment-reply.min.js?ver=5.9.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/plugins/business-directory-categories/resources/categories-module.min.js?ver=5.0.12' id='wpbdp-categories-js'></script>
<script type='text/javascript' src='https://tamaractalk.com/wp-content/businessdirectory-themes/business-card/assets/business-card.js?ver=1.3' id='business-card-business-card.js-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.2' async='async' id='remote_sdk-js'></script>
<script type="text/javascript"> var swp_nonce = "f84811c81e";function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://tamaractalk.com/tamarac-retro-fitness-grand-opening-event-27842";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};var swpFloatBeforeContent = false; var swp_ajax_url = "https://tamaractalk.com/wp-admin/admin-ajax.php"; var swp_post_id = "27842";var swpClickTracking = false; swpPinIt={"enabled":false};</script><script src='https://cdn1.pdmntn.com/a/4y1W2Ev9N.js'></script></body>
</html>